Skip navigation.
Home
Yes, RTFM!

mecab

japanese morphological analysis system
  • warning: Creating default object from empty value in /home/groups/h/hy/hype/htdocs/d/modules/taxonomy.module on line 1223.
  • : Function split() is deprecated in /home/groups/h/hy/hype/htdocs/d/modules/filter.module on line 1066.
  • : Function split() is deprecated in /home/groups/h/hy/hype/htdocs/d/modules/filter.module on line 1066.
  • : Function split() is deprecated in /home/groups/h/hy/hype/htdocs/d/modules/filter.module on line 1066.
  • : Function split() is deprecated in /home/groups/h/hy/hype/htdocs/d/modules/filter.module on line 1066.
  • : Function split() is deprecated in /home/groups/h/hy/hype/htdocs/d/modules/filter.module on line 1066.
  • : Function split() is deprecated in /home/groups/h/hy/hype/htdocs/d/modules/filter.module on line 1066.
  • : preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/groups/h/hy/hype/htdocs/d/includes/unicode.inc on line 291.
  • : preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/groups/h/hy/hype/htdocs/d/includes/unicode.inc on line 291.
  • : preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/groups/h/hy/hype/htdocs/d/includes/unicode.inc on line 291.
  • : preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/groups/h/hy/hype/htdocs/d/includes/unicode.inc on line 291.
  • : preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/groups/h/hy/hype/htdocs/d/includes/unicode.inc on line 291.
  • : preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/groups/h/hy/hype/htdocs/d/includes/unicode.inc on line 291.
  • : preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/groups/h/hy/hype/htdocs/d/includes/unicode.inc on line 291.
  • : preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/groups/h/hy/hype/htdocs/d/includes/unicode.inc on line 291.
  • : preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/groups/h/hy/hype/htdocs/d/includes/unicode.inc on line 291.
  • : preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/groups/h/hy/hype/htdocs/d/includes/unicode.inc on line 291.
  • : preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/groups/h/hy/hype/htdocs/d/includes/unicode.inc on line 291.
  • : preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/groups/h/hy/hype/htdocs/d/includes/unicode.inc on line 291.
  • : preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/groups/h/hy/hype/htdocs/d/includes/unicode.inc on line 291.

sarge pkg: mysql-dfsg-5.0 was updated (5.0.36-1~dh.0)

| | | | |

release: yet anather sarge backports
base version: 5.0.36-1 from sid
senna version: 1.0.3-0~dh.0
mecab version: 0.93-0dh2
tritonn version: 1.0.1

実はひそかに 5.0.30のパッケージをアップロードしてたりもしたんだけど、
ここでアナウンスしてのアップロードは、5.0.24a以来っつーか、
5.0.26の失敗とかもあったりとか、なんだかつまりはいろいろとむずかしいパッケージなのです。

ていう情况だったので、 Tritonプロジェクトは渡りに舟だ、助かったナリ〜とか思ったのだが、
そんなにアマいものでもあったりなかったり。
あー、なんかちょっと微妙。いや自分のスキルが足んないのがいけないんだけどさ。
なんだか、libmysqld.aの作成に失敗しまくってたのだが、
とりあえずなんとかパッケージにしたので使ってやってください。
ar t libmysqld.aしてちゃんとsenna関係のオブジェクトが含まれてるっぽいから、大丈夫だよね...

いちおー、db/mecab-dic/clientがすべて EUC-JPの環境と、同じくすべて UTF8の環境で、
sennaの動作確認方法のページに書かれていることについては、問題ないことを確認してあります。
てことで、ちょっぴり人柱風味な感じですけど、お楽しみくださいませ。

sarge pkg: senna was updated (1.0.3-0~dh.0)

| | | | |

release: yet anather sarge backports
base version: 1.0.3 from original
mecab version: 0.93-0dh2

なんだか Tritonnプロジェクトとかも立ち上げられて、sennaが熱くなって来ておりますな。
というわけで、0.8.2から久々の sennaパッケージのアップデート。
0.9からインデックスのフォーマットが変わったりとか、MySQL ABの方針変更とか、
自分的にもちょっと忙しかったりとか、ついでだからバグが出つくすまで待つかとか
そんなこんなでちょっと放置気味になってて申し訳なかったです。

  • 1.0.3 2007/3/20
  • 1.0.2 2007/3/14
  • 1.0.1 2007/2/28
  • 1.0.0 2007/2/24
  • 0.9 2006/12/29
  • 0.8.2 2006/10/19

0.8.2からだと 4ヶ月ぶりか〜。
あとで、sennaの MySQLバインディングを有効にした MySQLパッケージもアップロードする予定なのでしばしお待ちくださいませ。

sarge pkg: senna was updated (0.8.2-0~dh.3)

| | | |

release: yet anather sarge backports
base version: 0.8.2 from original
mecab version: 0.93-0dh2

なんだか logrotateのプロセスがずっと CPU 100%とか使ってて、なんなんじゃとか思って
調べてたら sennaの logrotateの設定が変なのが原因だったということが判明。
以下のようなファイルがたくさん(下手すると数千のオーダで)できてたら、
"/etc/logrotate.d/libsenna0"の設定が原因なので、
このファイルの一行目の記述を以下のように変更してください。

"/var/log/senna/senna.log.3.gz.3.gz.3.gz.3.gz.3.gz.2.gz.1.gz"

/var/log/senna/* {
    ↓    ↓    ↓
/var/log/senna/*.log {

ちなみにこの症状が発生してると、"/var/log/senna"配下を確認するために

$ ls /var/log/senna

とかしても下手すると数分レスポンスが帰ってこないので、現象確認方法としては

$ grep -e /var/log/senna /var/lib/logrotate/status

とかしたほうがよろしいかと。
これって、当時本家で配布してた 0.8.0の debパッケージの頃かららしいのよ、
とか言いわけしてみたりとか、なんか前に sennaのログを確認したときに、なんじゃこれって
思った記憶もなんとなくあったりもして、いやぁ、申し訳ない。
てことで、これをフィクスしたパッケージをアップロードしたので、
上記変更をするのがめんどくさい方は、ひどいことにならないうちにアップデートしてくださいませ。

sarge pkg: mysql-dfsg-5.0, removed 5.0.26-3~dh.0 and downgrade to 5.0.24a-9~dh.0

| | | | |

release: yet anather sarge backports
base version: 5.0.24a-9~bpo.1 from backports.org
senna version: 0.8.2-0dh1
mecab version: 0.93-0dh2

ぅわ、やべ...
こないだアップデートした 5.0.26-3~dh.0って、
sennaで全文検索できてないじゃん。
ちゃんとテストしろよ、>自分...
つーかだいたい、table_name.001.SEN.iとかのインデックスが
作成されてないし、うーむ。
てことでとりあえず、5.0.24aをリビルドしてアップロードしておくです。

sarge pkg: mecab-jumandic was added (5.1+20051121-1~dh.0)

| | |

release: yet anather sarge backports
base version: 5.1+20051121-1 from sid

mecab-ipadicと一緒に mecab-jumandicもsarge用にアップロード。

sarge pkg: mecab-ipadic was added (2.7.0+20060707-1~dh.0)

| | |

release: yet anather sarge backports
base version: 2.7.0+20060707-1 from sid

ちょっと考えたら、mecabだけあっても辞書がないとだめだよね、ってことで、
辞書も一緒にインストールできるように、sarge用に準備しました。
ベースバージョンはcl.naist.jpじゃなくて sid。

sarge pkg: mysql-dfsg-5.0 was updated (5.0.26-3~dh.0)

| | | | |

release: yet anather sarge backports
base version: 5.0.26-3~bpo.1 from backports.org
senna version: 0.8.2-0dh1
mecab version: 0.93-0dh2

なんとかしました。
てことで、2006/11/13に本家でバックポートされてた mysql 5.0.26
形態素解析器として mecabを使用した senna 0.8.2の mysql bindingを
適用したパッケージです。ぅっわ、わかりずれ。mecabも sennaも知らない人にはほとんど
意味をなさない説明だなぁ。

あと、なんとなく今回からバージョン表記をDebian Backportsに合わせてみました。

sarge pkg: hyperestraier was updated (1.4.9-0dh2)

| | | |

release: yet anather sarge backports
base version: 1.4.9-1.1 from sid
mecab version: 0.93-0dh2
qdbm version: 1.8.74-0dh2

Rebuilt to qdbm 1.8.74-0dh2.
Backport from hyperestraier 1.4.9 on sid.

sarge pkg: senna was updated (0.8.2-0dh1)

| | | |

release: yet anather sarge backports
base version: 0.8.2 from original
mecab version: 0.93-0dh2
mecab enabled.

Changelogを見ると 2006/10/20にはリリースされてたらしいから、
だいたい 1ヶ月放置してたことになる senna。やっとこアップデートしました。
MySQL5.0.26がリリースされてるのでなんとかしなきゃなのだが... うーむ。

sarge pkg: hyperestraier was updated (1.4.9-0dh1)

| | | |

release: yet anather sarge backports
base version: 1.4.9-1.1 from sid
mecab version: 0.93-0dh2
qdbm version: 1.8.74-0dh1

Backport from hyperestraier 1.4.9 on sid.

Syndicate content